Новости

WordPress дважды выпустил обновление с ошибками

Команда разработчиков WordPress в результате ряда ошибок выпустила некорректное обновление, которое сделало невозможным установку WordPress на новые сайты. Разработчики приостановили выпуск обновления, пытаясь его исправить, но это создало еще больше проблем, требующих экстренного решения.

Проблема началась 29 октября 2020 года с планового обновления. WordPress 5.5.2 был предназначен для предотвращения таких проблем, как подделка межсайтовых запросов, атаки XSS (межсайтовый скриптинг) и многое другое.

В обновлении была обнаружена ошибка, которая приводила к сбою новых установок WordPress.

WordPress 5.5.2… делает невозможным установку WordPress на новый веб-сайт, для которого не настроено подключение к базе данных. Этот выпуск не влияет на сайты, на которых уже настроено подключение к базе данных, например, с помощью установщиков в один клик или существующего файла wp-config.php , – объяснили ошибку разработчики.

Чтобы решить эту проблему, WordPress остановил развертывание версии 5.5.2 на других сайтах.

Но пока команда WordPress была занята подготовкой WordPress 5.5.3, чтобы исправить предыдущую ошибку, запустились автоматические обновления WordPress.

И поскольку версия 5.5.2 была недоступна, автоматизированная система WordPress выбрала для загрузки и установки альфа-версию WordPress, которая не предназначалась для автоматического обновления.

Проблема с установкой WordPress Alpha заключалась в том, что она вводила дополнительные темы WordPress и устанавливала Akismet.

WordPress 5.5.3

Эта версия призвана исправить проблему, появившуюся в WordPress 5.5.2.

Теперь разработчики рекомендуют издателям убедиться, что они обновлены до версии 5.5.3, т.к. версии до 5.5.2 содержат проблемы безопасности.

Источник: Search Engine Journal

Источник


Теги

Добавить комментарий

Кнопка «Наверх»
каталог сайтов
NofolloW.Ru
Каталог webplus.info
Закрыть
Закрыть